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Overview 
 
The MAM Player is a MIDI file player that generates various kinds of graphical displays 
in response to (and in sync with) the MIDI data as it plays.  It will also produce these 
displays in response to live MIDI input.   
 
 
 
Features 
 
• plays MIDI files with displays generated from MIDI data 
• generates displays in real-time from live MIDI input 
• display types: bar-graph, pitch class, interval type, tonality, triads 
 
 
 
Limitations 
 
• may not work on versions of Windows other than XP (under testing) 
• no Mac OS version available 
• does not record MIDI (except in a limited way; cannot save recorded MIDI) 
• custom display colors only saved in a proprietary (non-MIDI compatible) file format 
• MIDI System Exclusive messages are not handled (or saved to proprietary format) 
• file-related operations are poorly implemented (e.g. doesn’t prompt for overwrite) 
• some UI operations take a long time to complete (e.g. scrolling in long pieces) 
• doesn’t support borderless full-screen mode (for concert use) 
• mouse commands do not auto-repeat 
• no MIDI pass-through for live play mode 
 
 
 
Contents of this guide 
 
Page Description 
—— ——————————————————— 
2  Overview, Features, Limitations, Contents 
3 Quick Start 
4 Display Types and Display Options 
11 What’s in the menus 
12 Live Play 
13 Diagnostics and Debugging 
13 Note for Windows 7 
14 FAQ (aka “stuff I haven’t organized yet”) 
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Quick Start (5 steps) 
 
1. Download the MAMPlayer ZIP file from www.musanim.com/player 
 
2. Right-click the ZIP file and extract its contents into a folder: 
 

 
 
3. Double-click MAMPlayer.exe in that folder: 
 

 
 
4. Open one of the .mamx files: 
 

       
 
5. Press the space bar to start the piece playing. 
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Display Types and Display Options 
 
The MAM Player displays are selected in the Display type selection of the View menu: 
 

 
 
The display types are described briefly below.  More information is available in the 
online MAM History pages:   www.musanim.com/mam/mamhist.htm 
 
———————————————————————————————————— 
 
1. Piano Roll (MAM) Display 
 

 
 
This is the original Music Animation Machine display.  Time is shown left-to-right (past 
is toward the left of center; future is toward the right), pitch is shown bottom-to-top 
(higher notes are further toward the top).  There are various thing you can customize in 
this display: 
 
• width of the notes — up/down arrow keys 
• how the notes are colored — either “by part” (each instrument or line of music gets 

its own color), or “by pitch class” (all Cs have the same color, all Ds have the same 
color; more about this here:  www.musanim.com/mam/pfifth.htm ) 

• colors associate with the parts — right-click a note and select “Adjust color” 
• which pitch is the tonic (home key) used in “color by pitch class” display — right-

click a note and select “Set as tonic”; that note should turn blue 
• invert light-dark — in the View menu, select Invert light/dark (useful if you’re going 

to print the screen on white paper) 
• view note start lines — in the View menu, select “Note start lines ...” 
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2. Pitch Class (WHEEL) Display 
 

 
 
This is the “circle of fifths coloring” described in detail here:  
www.musanim.com/mam/pfifth.htm   In this version, pitch history during four time 
intervals is shown: the innermost ring shows whether a pitch is sounding right now, the 
next ring shows whether a note has been sounding in the last second or two, and so on to 
the outermost ring which takes a long time to build up and decay. 
 
There are no custom controls for this display (but the pitch that you “set as tonic” on the 
MAM display will be uppermost here). 
 
———————————————————————————————————— 
 
3. Intervals (DYAD) Display 
 

 
 
Shows interval types; described in detail here: www.musanim.com/mam/dyad.htm  
 
There are no custom controls for this display (but the pitch that you “set as tonic” on the 
MAM display will be uppermost here). 
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4. Interval + Pitch (YARN) Display 
 

 
 
This combines the interval type display with some indication of pitch and time.  It’s 
called YARN because somebody commented that it looks like a scrolling ball of yarn. 
 
See: www.musanim.com/mam/hist21.html 
 
———————————————————————————————————— 
 
5. Shapes Display 
 

 
 
Like the Pitch part of the YARN display, except that each part (instrument or voice) is 
given its own shape. 
 
See: www.musanim.com/mam/hist23.html 
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6. Tonality Staff (V12) Display 
 

 
 
Like the DYAD display, except that pitch is shown (left is low, right is high), and the 
twelve pitch classes are shown on staff lines (which move to keep the pitches centered.) 
 
See: www.musanim.com/mam/hist30.html 
 
There are no custom controls for this display (but the pitch that you “set as tonic” on the 
MAM display will be uppermost here). 
 
———————————————————————————————————— 
 
7. Tonality Compass Display 
 

 
 
Like DYAD, except that the pitches are given (metaphorical) weight (depicted as size of 
the circles) based on dynamic level and leverage based on how low they are (distance of 
the circles from the axis); the pitch complex moves toward tonal equilibrium (the point at 
which its center of gravity is lowest). 
 
See: www.musanim.com/mam/hist30.html 
 
There are no custom controls for this display (but the pitch that you “set as tonic” on the 
MAM display will be uppermost here). 
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8. Tonality Compass + Bars Display 
 

 
 
This combines the left-hand side of the MAM display with the Tonality Compass 
Display. 
 
See: www.musanim.com/mam/hist30.html 
 
See the MAM and Tonality Compass displays for descriptions of customization details. 
 
———————————————————————————————————— 
 
9. Triads (LATTICE) Display 
 

 
 
In this pitch-class display, pitches separated by an interval of a perfect fifth or perfect 
fourth are adjacent on a given horizontal line.  Pitches separated by a major or minor 
third are adjacent on a diagonal line.  When adjacent pitches are sounding, their 
indicators light up in the corresponding pitch class color, and connecting lines are drawn.  
For example, in the example shown here, a major seventh chord, we see two perfect fifths 
(1-5 and 3-7), two major thirds (1-3 and 5-7) and one minor third (3-5).  
 
See: www.musanim.com/mam/hist32.html 
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10. Part sequence (LINES) Display 
 

 
 
In this display (suggested by Stéphane Barbery), the notes are represented by circles (the 
size of which corresponds to the length of the note) and the notes of each part (a part is a 
unique track/channel combination) are connected sequentially by lines. 
 
In this display, you can control the size with the up/down arrow keys.  Changing the size 
of the window is useful, too, since the note sizes change with respect to that.  The Now 
line and Note Start lines are available in this display. 
 
———————————————————————————————————— 
 
11. Part motion (BALLS) Display 
 

 
 
Similar to LINES, in this one, the core of each ball detaches from its outline when the 
note is sounding, and moves toward the next not in the part (based on a suggestion by 
Douglas George).  The Now line and Note Start lines are available in this display. 
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12. Part trajectory (WEDGES) Display 
 

 
 
Similar to LINES and BALLS, but with only a small hint of where the sounding notes are 
(based on a suggestion by Carl Lumma).  The Now line and Note Start lines are available 
in this display. 
 
———————————————————————————————————— 
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What’s in the menus (and where to look for more information) 
 
File 
 Open (see Quick Start) 
 Save (see FAQ) 
 Save As (see FAQ) 
 Close (see FAQ) 
 Exit 
Edit <no available options> 
View 
 Display type ... (see Display Types and Display Options) 
  ... piano roll (MAM) 
  ... pitch class (WHEEL) 
  ... intervals (DYAD) 
  ... interval + pitch (YARN) 
  ... shapes 
  ... tonality staff (V12) 
  ... tonality compass 
  ... tonality compass + bars 
  ... triads (LATTICE) 
 Color by ... (see Display type ... piano roll (MAM)) 
  ... part (MIDI track/channel) 
  ... pitch class 
 Invert light/dark  (see Display type ... piano roll (MAM)) 
 Now line (see FAQ) 
 Note start lines ... (see FAQ) 
 MIDI keyboard menu (see FAQ) 
 Diagnostic window (see Diagnostics and Debugging) 
 Song Time (displays song position time) 
 Set tonic ... (see Display type ... piano roll (MAM)) 
  ... C, C-sharp, D, ... B 
MIDI 
 MIDI In (see Live Play) 
 MIDI Out (see FAQ) 
  Microsoft GS Wavetable SW Synth 
 Force Channel 1 (see FAQ) 
 Play/Pause (spacebar) (see Quick Start) 
 Live Play (see Live Play) 
Help <nothing of interest here> 
 
If you right-click a note in the piano roll (MAM) display, you will get a popup menu: 

 
 
 
Adjust color (see Display type ... piano roll (MAM)) 
Set as tonic (see Display type ... piano roll (MAM))
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Live Play 
 
If you have a MIDI keyboard attached to your computer, you can use the MAM Player’s 
Live Play feature. 
 
First, select your MIDI interface from the list of MIDI In devices in the MIDI In menu: 
 

 
 
Then, turn on Live Play mode: 
 

 
 
Because the MAM Player can’t guess what’s in the future, only the past (left-hand) part 
of the piano roll display will be visible: 
 

 
 
The MAM Player does not have a “thru” mode, so you’ll need to have local sound 
enabled on your MIDI keyboard.
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Diagnostics and Debugging 
 
To help diagnose problems with the MAM Player, I’ve included a diagnostic display; the 
window in which appears is enabled with this menu item: 
 

 
 
Internal problems with the software are sometimes detected and announced, like this:  
 

 
 
If this happens at about the same time a problem happens, it might be related. 
 
When you exit the program, everything in the diagnostic window is written to the log file 
 
 mamlog.txt 
 
 
So, if the MAM Player crashes, doesn’t work, etc., please send an email to  
 
 support@musanim.com 
 
with a description of the problem (especially the exact steps required to reproduce it) and 
the log file.  If it fails on a particular MIDI (or .mamx) file, send that too. 
 
 
 
Note for Windows 7 
 
If the graphics update seems slow when running under Windows 7, Right click on 
MAMPlayer.exe, select Compatibility, then Disable display scaling on high DPI 
settings, desktop composition and visual themes.
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FAQ 
 
Q: Can I record and save MIDI with the MAM Player? 
A: Sorry, no.  It’s only a player. 
 
Q: Then why do I see Save and  Save As in the File menu? 
A: Oh, right.  That’s because you can save the color settings for a particular song. 
 
Q: How come I can’t save the color settings in a MIDI file? 
A: Because it’s not part of the MIDI file spec. 
 
Q: What is Close in the File menu for? 
A: Not much; it just erases the screen if you have a song loaded. 
 
Q: The MAM movies I’ve seen on YouTube don’t have that obnoxious vertical line. 
A: You can turn that off with the Now Line setting in the View menu.  It’s visible in the 
MAM and LINES displays. 
 
Q: What’s this “MIDI keyboard menu” thing? 
A: If you have a MIDI keyboard plugged in, you can control some aspects of the program 
by pressing MIDI keys.  It’s probably not something most people will want to use; it’s 
only there because it’s part of the editor in the non-public version of the program I’m 
making for my own use. 
 
Q: Non-public version?  Editor? 
A: Forget I mentioned it. 
 
Q: The sound isn’t synchronized with the bars — it’s a little late. 
A: You’ve probably got Midi Out set to the “Microsoft GS Wavetable SW Synth” (the 
default Windows synthesizer), which has delays.  Most other synthesizers (either a 
software synth like GigaSampler or an external module) don’t have this problem. 
 
Q: When I play my MIDI file through my external synth, I don’t hear all the notes. 
A: I’m guessing that the MIDI file uses channels that your synth isn’t responding to.  If 
that’s the problem, try setting Force Channel 1 (in the MIDI menu); this will cause the 
MAM Player to replace all the channel numbers with 1. 
 
Q: How do I make a QuickTime or AVI or WMV movie of my MIDI file? 
A: I haven't tried doing this myself, but at least one user has reported good results by 
using the Hyperionics HyperCam software. 
 
Q: What can I do to see the rhythm more clearly? 
A: Try enabling either Local or Global Note Start lines (see View Menu). 
———————————————————————————————————— 
end 
———————————————————————————————————— 


